wiki:ndg_security/Apache2/mod_wsgi

Version 1 (modified by pjkersha, 10 years ago) (diff)

--

mod_wsgi Build and Installation

This must be rebuilt for Python 2.6 as the current library is built against Python 2.5. All steps assume execution as root id.

  1. Get latest mod_wsgi (as of writing version 3.2):
    $ wget http://code.google.com/p/modwsgi/downloads/detail?name=mod_wsgi-3.2.tar.gz
    $ tar zxvf ./mod_wsgi-3.2.tar.gz
    
  2. Configure, build and install:
    $ ./configure --with-apxs=/usr/sbin/apxs2-prefork --with-python=python2.6
    checking Apache version... 2.2.13
    configure: creating ./config.status
    config.status: creating Makefile
    
    $ make
    
    $ make install