Changes between Version 7 and Version 8 of CdatLite


Ignore:
Timestamp:
24/09/07 09:25:40 (12 years ago)
Author:
spascoe
Comment:

--

Legend:

Unmodified
Added
Removed
Modified
  • CdatLite

    v7 v8  
    3838== Installation == 
    3939 
    40 Binary eggs and the source tarball of cdat_lite are available from [http://ndg.nerc.ac.uk/dist].  It is also registered at the [http://cheeseshop.python.org/pypi Python Cheeseshop] so should be discovered automatically by {{{easy_install}}}. 
     40Cdat-lite uses [http://peak.telecommunity.com/DevCenter/EasyInstall easy_install] as it's installation mechanism.  This makes downloading and installing the software a one-step process, once you've installed the [http://peak.telecommunity.com/DevCenter/setuptools setuptools] package (itself very easy to install).   
    4141 
    42  1. Start with a python 2.4+ installation with distutils.  You cannot build or run the egg without distutils.  If your python has been installed by a unix package manager then you may have to install the python-devel package. 
    43  1. Install [http://peak.telecommunity.com/DevCenter/setuptools setuptools].  This includes the {{{easy_install}}} script.  Note as of version 0.6c5 of setuptools you no longer need the ez_setup.py bootstrap script.  Just download the appropriate setuptools egg and run it as a shell script: 
     42Binary eggs and the source tarball of {{{cdat_lite}}} are available from [http://ndg.nerc.ac.uk/dist].  It is also registered at the [http://cheeseshop.python.org/pypi Python Cheeseshop] so should be discovered automatically by {{{easy_install}}}. 
     43 
     44 1. Start with a python 2.4+ installation with distutils.  You cannot build or run the egg without distutils.  If your python has been installed by a unix package manager then you may have to install the python-devel package.  To check you've got distutils type the following at the Python prompt: 
    4445 {{{ 
    45  $ sh setuptools-0.6c5-py2.4.egg 
     46 >>> import distutils 
     47 >>> 
    4648 }}} 
    47  1. simply type: 
     49 1. Install [http://peak.telecommunity.com/DevCenter/setuptools setuptools].  This includes the {{{easy_install}}} script.  The setuptools website has detailed installation instructions but if you have write-permission to your python installation the following should work: 
     50 {{{ 
     51 $ wget http://peak.telecommunity.com/dist/ez_setup.py 
     52 $ python ez_setup.py 
     53 }}} 
     54 1. Now your ready to install cdat_lite.  Simply type: 
    4855 {{{ 
    4956 $ easy_install cdat_lite