Ticket #837 (closed task: fixed)

Opened 12 years ago

Last modified 12 years ago

setting PYTHON_EGG_CACHE environment variable

Reported by: domlowe Owned by: spascoe
Priority: required Milestone: PROD Step3
Component: community Version:
Keywords: Cc:

Description

The PYTHON_EGG_CACHE variable on glue had been set to /research/somethingorother/spascoe/..

We tried to add an export into the init.d script but it doesn't seem to work. Setting it in the console worked ok though. Where/how should it be set?

Change History

comment:1 Changed 12 years ago by spascoe

  • Status changed from new to assigned

The init.d script is wrong. paster serve doesn't understand the arguments start, stop and restart. Instead we should have

#!/bin/sh -e
export PYTHON_EGG_CACHE=/tmp
PID=/usr/local/NDGServices/paster.pid
INI=/usr/local/NDGServices/ows_server/development.ini
LOG=/usr/local/NDGServices/paster.log 
case "$1" in
  start)
    paster serve --daemon --reload --pid-file=$PID --log-file=$LOG $INI
    ;;
  stop)
    paster serve --stop-daemon --pid-file=$PID --log-file=$LOG $INI
    ;;
  restart)
    paster serve --stop-daemon --pid-file=$PID --log-file=$LOG $INI
    paster serve --daemon --reload --pid-file=$PID --log-file=$LOG $INI
    ;;
  *)
    echo $"Usage: $0 {start|stop|restart}"
    exit 1
esac

I haven't made these changes today because Bryan is demoing NDG from glue. I will close the ticket when applied.

comment:2 Changed 12 years ago by spascoe

  • Status changed from assigned to closed
  • Resolution set to fixed

Changed init.d script. The bug wasn't reproducable but logging in works now.

Note: See TracTickets for help on using tickets.