Ticket #836 (closed defect: fixed)

Opened 12 years ago

Last modified 12 years ago

[WG] Map interface issues

Reported by: lawrence Owned by: spascoe
Priority: critical Milestone: PROD Step3
Component: community Version:
Keywords: pylons Cc:

Description (last modified by domlowe) (diff)

  1. The default range needs to be global (90 North south etc, and clear form should go back to that - we don't need a clear selection for the map alone).
  2. The default should be select not move (on the map)
  3. When going 'back' either by 'refine search' or back button, the original spatial selection is lost.

Change History

comment:1 Changed 12 years ago by selatham

Will we have a choice of within, outside, overlaps? This functionality exists in Discovery WS back-end. Presumably it's defaulting to 'within' currently?

comment:2 Changed 12 years ago by domlowe

  • Description modified (diff)

It looks like the current setting is overlaps (which is probably the most sensible default).

comment:3 Changed 12 years ago by spascoe

  • Status changed from new to assigned

No. 1 & 2 are done ([2768]). No 3 is dependent on ticket:839.

comment:4 Changed 12 years ago by spascoe

  • Status changed from assigned to closed
  • Resolution set to fixed

Fixed in [2773]. Selection is retained whether returning to advanced search using the back button or "Refine Search".

Confirmed works with IE.

Note: See TracTickets for help on using tickets.