Ticket #832 (closed task: wontfix)

Opened 12 years ago

Last modified 12 years ago

[M] dgOnlineReferenceType disfunctional.

Reported by: lawrence Owned by: lawrence
Priority: desirable Milestone: Reporting
Component: MOLES Version:
Keywords: Cc:

Description

Currently this has either a simplelink or an xlink (which isn't a proper xlink, but that's another story) ... and a reference class. THe problem is that there is potential conflict between the reference class and the simple link name. In any case the consumer of this document either has to ignore the simple link name or the reference class and doesn't know which.

For example, given one of these things, what should browse show? This is exemplified in ticket:820, which is really about usage.

I think it would be better to rework this using xlink properly, and making it clear to the MOLES populator how it will be used in practice.

(e.g. linkname, roleoflink, targetoflink), so I could show <a href="targetoflink">linkname</a> and tooltip it to show roleoflink. But that's not what it currently looks like.

Change History

comment:1 Changed 12 years ago by selatham

  • Owner changed from ko23 to lawrence

comment:2 Changed 12 years ago by selatham

  • Status changed from new to closed
  • Resolution set to wontfix

future of moles.

Note: See TracTickets for help on using tickets.