Ticket #693 (closed defect: fixed)

Opened 12 years ago

Last modified 12 years ago

[M] Bug in Activity stub b xquery?

Reported by: lawrence Owned by: ko23
Priority: blocker Milestone: BETA
Component: MOLES Version:
Keywords: BROWSE Cc: selatham

Description

The metadataid element is surrounding nearly the whole record: see the attached example. Is this content or the xquery?

Attachments

tmp.xml Download (5.1 KB) - added by lawrence 12 years ago.
Example of stub-b returned
activity_activity_chablis.xml Download (37.1 KB) - added by lawrence 12 years ago.
Example activity from chinook
activity_activity_chablis.2.xml Download (27.3 KB) - added by ko23 12 years ago.
Chablis StubB (note that error elements are added by XQuery: perhaps we should talk about about error condition cases and structure to make life easier at the front end?)

Change History

Changed 12 years ago by lawrence

Example of stub-b returned

comment:1 Changed 12 years ago by ko23

A misplaced bracket, so I'll fix it IDC.

comment:2 Changed 12 years ago by lawrence

Actually, there's something wrong with the Activity one too; it seems to generate an infinite loop on chinook ...

(Can you do something about these in the back of your meeting, it's a blocker for any GUI development of browse, i.e. for BETA).

comment:3 Changed 12 years ago by ko23

  • Status changed from new to closed
  • Resolution set to fixed

Oh go on, as it's you...

Seriously, from the quick tests I've done, it looks like the ObsStn? one is the only one with a problem, so it's now fixed.

As there aren't any activities in the /db/discovery backup from glue, could you make the chinook version available for me to look at?

comment:4 Changed 12 years ago by lawrence

  • Status changed from closed to reopened
  • Resolution fixed deleted

Changed 12 years ago by lawrence

Example activity from chinook

comment:5 Changed 12 years ago by lawrence

  • Type changed from task to defect
  • Summary changed from [M] Bug in Observation Station stub b xquery? to [M] Bug in Activity stub b xquery?

As you can see I've added an activity to this ticket, and changed the ticket name. NB: could the activity_activity be the problem?

comment:6 Changed 12 years ago by selatham

Some badc records are actually called 'activity_activity_xxxx'. This is due to badc originally making ids activity_xxx when generating initial activities in the new catalogue. Then a prefix of 'activity' gets added giving the external localid activity_activity_xxx. Newer ids will look like activity_nnnnnn, where nnnnn=pure numeric.

comment:7 Changed 12 years ago by ko23

  • Status changed from reopened to closed
  • Resolution set to fixed

Loaded activity_activity_chablis.xml into my testdb, and xquery ran OK. However, I note that there's 25 deployments in there, and I don't seem to have access to the relevant des, dpts, and obsstns. It seems that, if there is a problem, the problem is going to be in the resolution of the deployments.

Hence, I repeat the request that the relevant data is made available.

Changed 12 years ago by ko23

Chablis StubB (note that error elements are added by XQuery: perhaps we should talk about about error condition cases and structure to make life easier at the front end?)

Note: See TracTickets for help on using tickets.