Ticket #637 (closed defect: fixed)

Opened 15 years ago

Last modified 15 years ago

[DS] cdms.Variable.name isn't always the NetCDF variable name

Reported by: spascoe Owned by: domlowe
Priority: required Milestone:
Component: CSML Version: 1.0
Keywords: Cc:


Working on CSML-v1.0x with DDC data I cannot subset a GridSeriesFeature? because csmldataiface.py:cdunifInterface:getSubsetOfDataForVar() uses self.varobj.name as the name of the NetCDF variable. This should be self.varobj.id.

I will change this in the CSML-v1.0x-ddc branch. The CSML2 code should be checked.

Change History

comment:1 Changed 15 years ago by domlowe

  • Status changed from new to closed
  • Resolution set to fixed

Fixed this in CSML 2.

Note: See TracTickets for help on using tickets.