Ticket #356 (closed task: fixed)

Opened 13 years ago

Last modified 11 years ago

[m] Stub-b examples don't have related_url in them.

Reported by: lawrence Owned by: sdonegan
Priority: required Milestone: PROD Final
Component: MOLES Version:
Keywords: Cc:

Description (last modified by lawrence) (diff)

... or maybe they do, and it's a content problem ...

See for example:  http://glue.badc.rl.ac.uk/cgi-bin/browse.py?uri=badc.nerc.ac.uk/dataent3&xml=1 and compare it with the dif content that comes with a search on era40 ... which does have the related url in it ...

 http://glue.badc.rl.ac.uk/cgi-bin/browse.py?D=1/uri=badc.nerc.ac.uk/dataent3?

shows that Kev isn't picking it up either ... so the content isn't there.

The badc difs are handcrafted, and moles was created from those ... but no one populated the related_url's in moles. Where should they go?

Change History

comment:1 Changed 13 years ago by lawrence

  • Description modified (diff)
  • Milestone changed from ALPHA to PostAlpha_review

comment:2 Changed 13 years ago by ko23

Sorry, which related_url? Description sections, A service, or B service?

comment:3 Changed 13 years ago by lawrence

Not a and b services ... things like links to web pages ... things that map onto related_url in a DIF ...

comment:4 Changed 13 years ago by selatham

Here's what happened in the ndg-to-dif xsl regarding what to put in related_url as per NDG1. It only considered looking for 'A' services. It is documented in the NDG1 MOLES guide  http://bscw.badc.rl.ac.uk/bscw/bscw.cgi/d51183/NDG_MOLES_Instructions_for_Creation.doc , section 4.2.3 dgDataGranule. It is out-of-date now and I don't know what Kev's MOLES-to DIF XQuery does, but it should have been something similar. No doubt for the post-Alpha review we need to decide what to do differently:-

<!-- work out what, if any, A service is available. Have to look at 'scheme' part if datasetID -->

<xsl:for-each select="//dgMetadataRecord/dgDataEntity/dgDataGranule">

<xsl:choose>

<xsl:when test="./dataModelID/schemeIdentifier='NDG-A0'">

<Related_URL>

<URL_Content_Type>NDG_A_SERVICE</URL_Content_Type> <URL> http://dmgdev1.esc.rl.ac.uk/cgi-bin/ndgDataAccess?datasetSource=dmgdev1.esc.rl.ac.uk&amp;datasetID=</URL> <Description>The NDG service delivering data via NDG A metadata.</Description>

</Related_URL>

</xsl:when> <xsl:when test="./dataModelID/schemeIdentifier= 'CDML-0'">

<Related_URL>

<URL_Content_Type>NDG_A_SERVICE</URL_Content_Type> <URL> http://cdat.badc.nerc.ac.uk/cgi-bin/dxui.py?datasetURI_1=/</URL> <Description>The NDG service delivering data via NDG CDML.</Description>

</Related_URL>

</xsl:when> <xsl:when test="./dataModelID/schemeIdentifier= 'URI'">

<Related_URL>

<URL>

<xsl:value-of select="./instance/URI"></xsl:value-of>

</URL>

</Related_URL>

</xsl:when> </xsl:choose>

</xsl:for-each>

comment:5 Changed 13 years ago by selatham

The example ERA40 MOLES and DIF records Bryan gives have been created by-hand a long time ago, so information did not neccessarily flow from B-to-D.

comment:6 Changed 13 years ago by siva

Using Kev's MOLES-->DIF 'bulkdestubb.jar' file, the DIF that is generated from a BODC MOLES(having A service) has the following in the <Related_URL/>.Though the URL seems to be not the proper one.


<Summary>Sea level time series from the Lea tide gauge at Wick between January 1972 and December 1975</Summary>

  • <Related_URL> <URL_Content_Type>NDG_B_SERVICE</URL_Content_Type> <URL>grid.bodc.nerc.ac.uk</URL> <Description>The NDG service for browsing metadata.</Description> </Related_URL>
  • <Related_URL> <URL_Content_Type>NDG_A_SERVICE</URL_Content_Type> <URL>http%3A%2F%2Fdmgdev1.esc.rl.ac.uk%2Fcgi-bin%2FndgDataAccess%3FdatasetSource%3Ddmgdev1.esc.rl.ac.uk%26datasetID%3D</URL> <Description>The NDG service delivering data via NDG A metadata.</Description> </Related_URL>

comment:7 Changed 13 years ago by lawrence

  • Priority changed from critical to required
  • Milestone changed from PostAlpha_review to ISO19115_PreBeta

comment:8 Changed 13 years ago by selatham

  • Type changed from issue to task

This seems to boil down to Kev checking that the MOLES-->DIF 'bulkdestubb.jar' is picking up the correct thing from MOLES to go into DIF Related_URL. If it's correct then close the ticket.

The rest of the issue is BADC content creation pipe issues see #349.

comment:9 Changed 13 years ago by ko23

  • Status changed from new to assigned

The related URL, other than "A", "B", and data access URIs (which should have an accompanying "instance" element), are from the "dgMetadataDescription/descriptionSection/descriptionOnlineReference" elements. I believe the xqueries are correct, but in order to check that this is so, please run the XQuery below on eXist and see if there are any hits.

for $DE in collection('ndg_B_metadata')/dgMetadata/dgMetadataRecord[exists(dgDataEntity) and exists(dgMetadataDescription/descriptionSection/descriptionOnlineReference)]
return
element record {
element ID {concat(data($DE/dgMetadataID/repositoryIdentifier),':',data($DE/dgMetadataID/schemeIdentifier),':',data($DE/dgMetadataID/localIdentifier))
},
element descriptionURLs {
$DE/dgMetadataDescription/descriptionSection/descriptionOnlineReference
    }
}

If you get any hits, please contact me directly.

comment:10 Changed 13 years ago by hsnaith

  • Milestone changed from ISO19115_PreBeta to PreBeta

Milestone ISO19115_PreBeta deleted

comment:11 Changed 13 years ago by ko23

  • Owner changed from ko23 to selatham
  • Status changed from assigned to new

The DIF queries should pick up NDG-A, NDG-B, and description sections that are URLs; and no one has reported getting hits from the XQuery in this listing, hence this looks likea population issue.

comment:12 Changed 12 years ago by selatham

  • Status changed from new to closed
  • Resolution set to wontfix

comment:13 Changed 12 years ago by lawrence

  • Status changed from closed to reopened
  • Resolution wontfix deleted

This is not about A and B services, it's about related URL content. let's not close it til we know the answer ...

comment:14 Changed 12 years ago by selatham

  • Owner changed from selatham to ko23
  • Status changed from reopened to new

URLs are still incorrect. There is BADC moles content for URLs, but t's not coming across. Now coming out as:-

<Related_URL>
		<URL/>
		<Description>URL to aid in delivering data. Note that this may point directly to the data or, more likely, point to the web site of the curator.</Description>
	</Related_URL>
	<Related_URL>
		<URL/>
		<Description> - </Description>
	</Related_URL>
	<Related_URL>
		<URL/>
		<Description> - </Description>
	</Related_URL>

comment:15 Changed 12 years ago by selatham

  • Milestone changed from BETA to PROD Step1

This is content. This is a problem with bulkdestubb.jar not dealing with URLs correctly.

comment:16 Changed 12 years ago by selatham

  • Owner changed from ko23 to sdonegan

Related to #644. Do that ticket first then see if these problems are cured.

comment:17 Changed 12 years ago by selatham

  • Milestone changed from PROD Step1 to PROD Final

comment:18 Changed 11 years ago by selatham

  • Status changed from new to closed
  • Resolution set to fixed

The problem with moles2dif adding old data services URLs has been solved by re-writing the bulk Discovery metadata code to utilise pure python access to exist. This made it much easier to update a definitive moles2dif XQuery and implement in the ndgUtils egg. There is still a problem with it adding 'Browseserver' links. This is mentioned separately in #935.

Note: See TracTickets for help on using tickets.