Ticket #283 (closed issue: fixed)

Opened 13 years ago

Last modified 12 years ago

[WG] Should CSML (for BADC) be stored in eXist or in file system?

Reported by: domlowe Owned by: domlowe
Priority: discussion Milestone: PROD Step1
Component: community Version:
Keywords: Cc:

Description

What do we want to do about CSML storage longterm? (within the BADC specifically but of interest to wider NDG.)

Should we use eXist?

For now it is simplest to store them as files, but this may or may not be the best longterm solution.

Change History

comment:1 Changed 13 years ago by siva

For the alpha stage, Iam going to store BODC CSML(only 2 records) in eXist itself, with a collection name "ndg_bodc_csml".

comment:2 Changed 13 years ago by selatham

  • Status changed from new to assigned

Do we want XQuery (or XUpdate) functionality on CSML? If so, needs to go in a db. What are the other use cases for CSML? If it's being retreived by services, how do they know where to get it? A URL?

Probably OK to store in eXist for now as long as it's in a separate collection to dif and ndg_b_metadata collections. Should we standardise on a collection name, e.g. ndg_csml_metadata?

If store as flat files, must ensure they are being backed up.

comment:3 Changed 12 years ago by selatham

  • Owner changed from selatham to domlowe
  • Status changed from assigned to new

Passing this to Dominic as I know he is addressing. This may be a duplicate of some other ticket he has.

comment:4 Changed 12 years ago by domlowe

  • Status changed from new to assigned
  • Milestone changed from BETA to PROD Step1

Sue, Bryan, Stephen, Dom need to agree on what we're doing. CSML code can access eXist or the filesystem.

comment:5 Changed 12 years ago by domlowe

  • Status changed from assigned to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.