Ticket #1118 (new defect)

Opened 9 years ago

[S] Fix SSL Authentication WSGI so that cookie expiry is co-ordinated correctly with cert expiry

Reported by: pjkersha Owned by: pjkersha
Priority: required Milestone:
Component: security Version:
Keywords: Cc:

Description

The ndg.security.server.wsgi.ssl middleware should be updated to ensure cookie expiry is updated to agree with the expiry of the user cert. used. This should ensure however that it does not exceed some sensible max. e.g. if a server EEC was used it might have an expiry year(s) in advance!

Note: See TracTickets for help on using tickets.