Ticket #1109 (closed defect: fixed)

Opened 10 years ago

Last modified 8 years ago

Truncated CDATA content

Reported by: mnagni Owned by: mnagni
Priority: desirable Milestone:
Component: discovery Version:
Keywords: CDATA Cc:

Description

1) The following query produces a response that elicits an XML parser error: "CData section not finished".

<SOAP-ENV:Envelope xmlns:ns0="http://medin.discovery.services.ndg/schema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/">

<SOAP-ENV:Header/> <SOAP-ENV:Body>

<ns0:DoPresent>

<ns0:Documents>

<ns0:DocumentId>dassh.ac.ukMEDIN_2.3MRMLN004000000E1.xml</ns0:DocumentId>

</ns0:Documents> <ns0:RetrieveCriteria>

<ns0:RecordDetail>DocumentFull?</ns0:RecordDetail> <ns0:MetadataFormat>MEDIN_2.3</ns0:MetadataFormat>

</ns0:RetrieveCriteria>

</ns0:DoPresent>

</SOAP-ENV:Body>

</SOAP-ENV:Envelope>

Attachments

soapResponse Download (52.6 KB) - added by mnagni 10 years ago.
Example of wrong SOAP response

Change History

Changed 10 years ago by mnagni

Example of wrong SOAP response

comment:1 Changed 10 years ago by mnagni

The error is caused by some unidentified situation by which AXIS truncates the response inside the CDATA element. Actually there are no other case like this are raised (or found).

comment:2 Changed 10 years ago by mnagni

  • Status changed from new to assigned

comment:3 Changed 8 years ago by mnagni

  • Status changed from assigned to closed
  • Resolution set to fixed

The problem was due to some component in AXIS2. The migration to JBoss removed the problem

Note: See TracTickets for help on using tickets.