Ticket #1104 (assigned defect)

Opened 9 years ago

Last modified 9 years ago

OAI Info Editor App Broken Security Plugin

Reported by: pjkersha Owned by: sdonegan
Priority: blocker Milestone: MEDIN
Component: discovery Version:
Keywords: Cc:

Description

The OAI Info Editor has a plugin to do a redirect to handle security policy. This has a broken import which causes a 500 Internal Server Error:

[Thu Feb 25 11:27:08 2010] [error] [client 130.246.188.20]   File "/usr/local/ndg-oai-info-editor/eggs/oai_info_editor-0.0.0dev_r5673-py2.5.egg/oai_info_editor/lib/security_redirector.py", line 30, in <module>
[Thu Feb 25 11:27:08 2010] [error] [client 130.246.188.20]     from ndg.security.server.wsgi.authz import PIPMiddlewareConfigError, \\
[Thu Feb 25 11:27:08 2010] [error] [client 130.246.188.20] ImportError: cannot import name PIPMiddlewareConfigError

Removing the PIPMiddlewareConfigError import fixes.

Change History

comment:1 Changed 9 years ago by sdonegan

  • Status changed from new to assigned

Work is now continuing to fix the NDG3 OAI_INFO_Editor as well as deploy a new info editor for MEDIN and its related data centres, to allow control over MEDIN format ingest.

Note: See TracTickets for help on using tickets.