Ticket #1043 (closed issue: worksforme)

Opened 11 years ago

Last modified 10 years ago

[M] Sampling Features versus Flight Paths in MOLES Deployments

Reported by: lawrence Owned by: lawrence
Priority: required Milestone: NDG3
Component: MOLES Version:
Keywords: simonc Cc:

Description

If we look at the current version (3.2,rev 1981) of the MOLES deployment diagram, attached, we see that we have a few things which are geometrical properties of the path of the platform, and these do not necessarily correspond identically to the sampling features associated with the result.

Bryan needs to clarify this in a possible V 3.3 so that the properties of, and distinctions between, platforms and sampling features are clear.

e.g. a flight or cruise make observations, in which case the csml feature types, which are sampling manifolds are *potentially* independent of the trajectory of the platform from which the observations were made. However, the aggregatoin of observations might share the trajectory locations ... also for example, a flight might make airspeed obs along the trajectory. I still see this as a logically distinct use of the trajectory.

So, in my mind, the trajectory, orbit, and scence which appear in deployments share heritage from gm_curve etc (and do have bounding boxes), but they are not properties of the results per se, and thus shouldn't be sampling manifolds - even if the same trajectory does appear in both places.

That said, we have some relationships to "visited sites" which are logically similar I suppose to "flight paths" but the problem is that the flight path has these two roles: as the site from which observations are launched, and as the site of observations ...

Attachments

Summary Deployment 3.2 rev 1981.png Download (421.1 KB) - added by lawrence 11 years ago.

Change History

Changed 11 years ago by lawrence

comment:1 Changed 11 years ago by lawrence

  • Status changed from new to assigned
  • Keywords simonc added

comment:2 Changed 11 years ago by lawrence

Email from Simon: on reflection, it is clearly overloading SamplingFeature? to make it supply the 'path' of a flight or cruise, which after all is just a Curve. In some contexts Flight or Cruise do not have enough additional properties to merit a new class, and may in fact just be a SamplingFeature?, but in this context an additional property is warranted FlightOrCruise?-->path:GM_Curve

All 'Deployments' (field trips, flights, cruises) may have an association with various kinds of sampling features, with the role "observationSite".

comment:3 Changed 10 years ago by lawrence

  • Status changed from assigned to closed
  • Resolution set to worksforme

This has been resolved in current versions (rev > 1995).

Note: See TracTickets for help on using tickets.