Changeset 7578 for cowsserver


Ignore:
Timestamp:
08/10/10 14:56:15 (9 years ago)
Author:
astephen
Message:

Changes for new python 2.6 and pylons 1.0 version.

Location:
cowsserver/branches/migrate-py26-pylons10
Files:
2 edited

Legend:

Unmodified
Added
Removed
  • cowsserver/branches/migrate-py26-pylons10/buildout/buildout.cfg

    r7340 r7578  
    1010interpreter = py 
    1111eggs = 
    12   geoplot 
    13   basemap 
    14   matplotlib 
    1512  numpy==1.3.0 
    16   image_utils 
     13  pycairo==1.2.2 
     14  PIL==1.1.7 
     15  Shapely==1.2.5   
     16  cdat-lite==5.2-1 
     17  geoplot>=0.4.0 
     18  csml==2.7.13   
    1719  Pylons==1.0 
    18   cdat_lite 
    19   Paste 
    20   PasteScript 
    21   Genshi 
    22   csml 
    23   cows 
    24   nose 
    25   mock 
    26   setuptools 
    27   cowsserver 
    28   simplejson 
    29   Shapely 
    30 # used for testing 
    31   libxml2dom 
    32   owslib  
     20  Beaker==1.5.4 
     21  decorator==3.2.0  
     22  FormEncode==1.2.3dev 
     23  Mako==0.3.4 
     24  MarkupSafe==0.11   
     25  nose==0.11.4   
     26  Paste==1.7.5.1 
     27  PasteDeploy==1.3.4 
     28  PasteScript==1.7.3 
     29  Routes==1.12.3 
     30  simplejson==2.1.1 
     31  Tempita==0.5dev 
     32  WebError==0.10.2 
     33  WebHelpers==1.2 
     34  WebOb==1.0 
     35  WebTest==1.2.2  
     36  Genshi==0.6 
     37  OWSLib==0.3.1      
     38  matplotlib==1.0.0   
     39  basemap==1.0 
     40  mock==0.7.0b2 
     41  wsgiref==0.1.2   
     42  cows>=1.6.0 
     43  cowsserver>=1.6.0 
     44   
     45# For testing only 
     46#  libxml2-python==2.6.21 
     47#  libxml2dom==0.4.7 
     48 
  • cowsserver/branches/migrate-py26-pylons10/setup.py

    r7340 r7578  
    88setup( 
    99    name='cowsserver', 
    10     version='1.5.1', 
     10    version='1.6.0', 
    1111    #description='', 
    1212    #author='', 
     
    1414    #url='', 
    1515    find_links=['http://ndg.nerc.ac.uk/dist'], 
    16     install_requires=["Pylons>=1.0", 'csml', 'genshi'], 
     16    install_requires=['Pylons>=1.0', 'genshi>=0.6', 'numpy==1.3.0', 'cdat_lite>=5.2', 'csml>=2.7', 
     17                      'pycairo>=1.2', 'Shapely>=1.2.5', 'PIL>=1.1.7', 
     18                      'matplotlib==1.0.0', 'basemap==1.0.0', 
     19                      'mock>=1.7', 'owslib==0.3.1', 'geoplot>=0.4.0', 'image_utils>=1.1.0'], 
    1720 
    1821    packages=find_packages('lib'), 
Note: See TracChangeset for help on using the changeset viewer.