Ignore:
Timestamp:
08/10/10 14:22:04 (10 years ago)
Author:
astephen
Message:

Committed changes to be compatible with Matplotlib and Basemap versions
1.0.0. Note that these changes "should" be backwards compatible.
Egg created from this version.

File:
1 edited

Legend:

Unmodified
Added
Removed
  • qesdi/geoplot/trunk/lib/geoplot/map_national_grid.py

    r5710 r7577  
    3434 
    3535def addBasemap(resolution): 
     36    
     37    # Create a basemap with the origin at the true origin. 
     38    # In order to cope with different Basemap versions you may need to 
     39    # Define the rsphere argument as the major and minor axis (of the sphere) 
     40    # - documented at: 
     41    #  http://proj.badc.rl.ac.uk/ndg/wiki/CowsFramework/CowsInstallation/MigrationToPython2.6?version=9#BasemapproblemwithTransverseMercatorprojection 
     42    rsphere = [6378137.00, 6356752.3142] 
     43 
    3644     
    3745    llBasemaps[resolution] = \ 
     
    4452                    urcrnrlat=bmyLimits[1], 
    4553                    resolution=resolution, 
     54                    rsphere = rsphere, 
    4655                    suppress_ticks=False) 
    4756         
Note: See TracChangeset for help on using the changeset viewer.