Changeset 3057


Ignore:
Timestamp:
27/11/07 11:33:00 (12 years ago)
Author:
pjkersha
Message:

python/ndg-security-install.py: if -U and -a are set to upgrade all, ensure all ndg_security dependencies (ndg_security_server, ndg_security_common and ndg_security_client) are included explicitly otherwise they get left out.

File:
1 edited

Legend:

Unmodified
Added
Removed
  • TI12-security/trunk/python/ndg-security-install.py

    r3048 r3057  
    181181        elif self.opt.installAll: 
    182182            log.info("Installing all ...") 
    183             ndgSecurityArgs = args + ["ndg_security"] 
    184             main(ndgSecurityArgs) 
    185             ndgSecurityTestArgs = args + ["ndg_security_test"] 
    186             main(ndgSecurityArgs) 
     183            args += ["ndg_security", "ndg_security_test"] 
     184            if self.opt.upgrade: 
     185                # If upgrade is set dependencies for ndg_security aren't 
     186                # updated - they need to be added explicitly 
     187                args += ["ndg_security_common",  
     188                         "ndg_security_server", 
     189                         "ndg_security_client"]  
     190            main(args) 
    187191            self.installTwisted() 
    188192             
Note: See TracChangeset for help on using the changeset viewer.