Ignore:
Timestamp:
21/06/07 15:05:06 (13 years ago)
Author:
spascoe
Message:

Added cache code but performance is still sluggish. Need to work out
exactly what's going on.

File:
1 edited

Legend:

Unmodified
Added
Removed
  • TI05-delivery/ows_framework/trunk/ows_server/ows_server/tests/functional/test_csml_wms.py

    r2596 r2630  
    66wms_ns = 'http://www.opengis.net/wms' 
    77 
    8 # This depends on the value randomly generated by csmlscan. 
    9 # However make_data.py sets the random seed so this should work. 
    10 test_feature_id = 'DVVhDIq2' 
     8# Test id is hard coded for now until I work out how to get it dynamically within 
     9# the test harness. 
     10test_feature_id = 'QGYylL9h' 
    1111 
    1212class TestGetCapabilities(TestController): 
    1313    def setUp(self): 
    1414        url = url_for(controller='csml_wms', 
    15                       file='test', 
     15                      file='clim_10', 
    1616                      request='GetCapabilities', 
    1717                      service='WMS', 
     
    3535        # With 4 sub-layers 
    3636        layers = layers[0].findall('./{%(ns)s}Layer' % dict(ns=wms_ns)) 
    37         assert len(layers) == 4 
     37        assert len(layers) == 9 
    3838 
    3939class TestGetMap(TestController): 
    4040    def setUp(self): 
    41         url = url_for(controller='csml_wms', file='test', 
     41        url = url_for(controller='csml_wms', file='clim_10', 
    4242                      request='GetMap', 
    4343                      layers=test_feature_id, 
Note: See TracChangeset for help on using the changeset viewer.