Changeset 1642


Ignore:
Timestamp:
27/10/06 13:36:34 (13 years ago)
Author:
pjkersha
Message:

Created common package for modules common to client and server packages. Moved into a separate package
as egg setuptools requires security package to be clear of modules.

Location:
TI12-security/trunk/python
Files:
1 added
2 edited
23 moved

Legend:

Unmodified
Added
Removed
  • TI12-security/trunk/python/ndg/security/__init__.py

    r483 r1642  
     1"""NERC Data Grid Project 
     2 
     3P J Kershaw 27/10/06 
     4 
     5Copyright (C) 2006 CCLRC & NERC 
     6 
     7This software may be distributed under the terms of the Q Public License, 
     8version 1.0 or later. 
     9 
     10This is a setuptools namespace_package.  DO NOT place any other 
     11code in this file!  There is no guarantee that it will be installed 
     12with easy_install.  See: 
     13 
     14http://peak.telecommunity.com/DevCenter/setuptools#namespace-packages 
     15 
     16... for details. 
     17""" 
     18__import__('pkg_resources').declare_namespace(__name__) 
  • TI12-security/trunk/python/setup.py

    r1641 r1642  
    2424# Get latest SubVersion revision for use with release ID 
    2525_svnRev = "$Revision$" 
    26 _version = 'DevPostAlpha + "Revision" in _svnRev and '' or "-" + _svnRev 
     26if "Revision" in _svnRev: 
     27    _version = 'DevPostAlpha' 
     28else: 
     29    _version = "DevPostAlpha-" + _svnRev 
    2730 
    2831# Packages needed for NDG Security 
     
    4245    'pyXMLSec'] 
    4346 
     47entry_points = { 
     48        'console_scripts': [ 
     49            'ndgSessionClient = ndg.client.ndgSessionClient:main'] 
     50 
    4451setupKw = \ 
    4552{ 
     
    5057    'author':                   'Philip Kershaw', 
    5158    'author_email':             'P.J.Kershaw@rl.ac.uk', 
     59    'maintainer':               'Philip Kershaw', 
     60    'maintainer_email':         'P.J.Kershaw@rl.ac.uk', 
    5261    'url':                      'http://proj.badc.rl.ac.uk/ndg', 
    5362    'install_requires':         _pkgDependencies, 
Note: See TracChangeset for help on using the changeset viewer.