source: qesdi/geoplot/trunk/setup.py @ 7577

Subversion URL: http://proj.badc.rl.ac.uk/svn/ndg/qesdi/geoplot/trunk/setup.py@7577
Revision 7577, 537 bytes checked in by astephen, 10 years ago (diff)

Committed changes to be compatible with Matplotlib and Basemap versions
1.0.0. Note that these changes "should" be backwards compatible.
Egg created from this version.

Line 
1from setuptools import setup, find_packages
2
3setup(
4    name='geoplot',
5    version='0.4.0',
6
7    # All packages are located in the lib directory
8    packages=find_packages('lib', exclude=['geoplot.tests.*']),
9    package_dir={'': 'lib'},
10
11    # include all .txt and .ini files, not using 'include_package_data = True'
12    # so that eggs can be built form exports rather than checkouts.
13    package_data = {
14        '': ['*.txt', '*.ini', '*.xml'],
15    },
16
17
18    tests_require=['nose>=0.10.3'],
19    test_suite="nose.collector"
20   
21    )
Note: See TracBrowser for help on using the repository browser.