source: cowsclient/trunk/setup.py @ 5822

Subversion URL: http://proj.badc.rl.ac.uk/svn/ndg/cowsclient/trunk/setup.py@5822
Revision 5822, 883 bytes checked in by domlowe, 10 years ago (diff)

updating version no

Line 
1try:
2    from setuptools import setup, find_packages
3except ImportError:
4    from ez_setup import use_setuptools
5    use_setuptools()
6    from setuptools import setup, find_packages
7
8setup(
9    name='cowsclient',
10    version="0.2.8", 
11    #description='',
12    #author='',
13    #author_email='',
14    #url='',
15    install_requires=["Pylons==0.9.6.1", "genshi"],
16    packages=find_packages(exclude=['ez_setup']),
17    include_package_data=True,
18    test_suite='nose.collector',
19    package_data={'cowsclient': ['i18n/*/LC_MESSAGES/*.mo']},
20    #message_extractors = {'cowsclient': [
21    #        ('**.py', 'python', None),
22    #        ('templates/**.mako', 'mako', None),
23    #        ('public/**', 'ignore', None)]},
24    entry_points="""
25    [paste.app_factory]
26    main = cowsclient.config.middleware:make_app
27
28    [paste.app_install]
29    main = pylons.util:PylonsInstaller
30    """,
31)
Note: See TracBrowser for help on using the repository browser.