source: TI12-security/trunk/python/ndg.security.common/setup.py @ 4143

Subversion URL: http://proj.badc.rl.ac.uk/svn/ndg/TI12-security/trunk/python/ndg.security.common/setup.py@4143
Revision 4143, 2.8 KB checked in by pjkersha, 11 years ago (diff)

Updated overall version to 0.9.3

  • Property svn:keywords set to Id
Line 
1#!/usr/bin/env python
2
3"""Distribution Utilities setup program for NDG Security Package
4
5NERC Data Grid Project
6"""
7__author__ = "P J Kershaw"
8__date__ = "24/04/06"
9__copyright__ = "(C) 2007 STFC & NERC"
10__license__ = \
11"""This software may be distributed under the terms of the Q Public
12License, version 1.0 or later."""
13__contact__ = "P.J.Kershaw@rl.ac.uk"
14__revision__ = '$Id$'
15
16# Bootstrap setuptools if necessary.
17from ez_setup import use_setuptools
18use_setuptools()
19
20from setuptools import setup, find_packages
21
22import os, sys
23
24__revision__ = "$Id$"
25
26
27# Packages needed for NDG Security
28# Note commented out ones fail with PyPI - use explicit link instead
29# TODO: subdivide these into server and client specific and comon dependencies
30_pkgDependencies = [
31    'PyXML', # include as a separate dependency to force correct download link
32    'ZSI',
33    '4Suite-XML',
34    'pycrypto',
35    'M2Crypto'
36    ]
37
38# TODO: configure an option so that database support can be set for the
39# Credential Repository.  MySQL package may need to be in its own option
40# eventually
41credReposDbSupport = False
42if credReposDbSupport:
43    _pkgDependencies += [
44    'SQLObject',
45    'MySQL-python', # TODO: fix gcc error: unrecognized option `-restrict'
46]
47
48# Python 2.5 includes ElementTree by default
49if sys.version_info[0:2] < (2, 5):
50    _pkgDependencies += ['ElementTree', 'cElementTree']
51
52# Sledge hammer approach needed with some packages as they won't install from
53# their PyPI name - instead give explicit URLs to search.  This may cause
54# problems later!
55_pkgDependencyLinks = [
56    # Custom M2Crypto for use with Python MyProxy client
57    "http://ndg.nerc.ac.uk/dist"
58]
59
60
61setup(
62    name =                      'ndg_security_common',
63    version =                   '0.9.3',
64    description = \
65'''NERC DataGrid Security virtual package containing common utilities used
66noth by server and client packages''',
67    long_description =          'Software for securing NDG resources',
68    author =                    'Philip Kershaw',
69    author_email =              'P.J.Kershaw@rl.ac.uk',
70    maintainer =                'Philip Kershaw',
71    maintainer_email =          'P.J.Kershaw@rl.ac.uk',
72    url =                       'http://proj.badc.rl.ac.uk/ndg/wiki/T12_Security',
73    license =               'Q Public License, version 1.0 or later',
74    install_requires =          _pkgDependencies,
75    dependency_links =          _pkgDependencyLinks,
76    packages =                  find_packages(),
77    namespace_packages =        ['ndg', 'ndg.security'],
78    # This flag will include all files under SVN control or included in
79    # MANIFEST.in.
80    #include_package_data =     True,
81    # Finer grained control of data file inclusion can be achieved with
82    # these parameters.  See the setuptools docs.
83    #package_data =             {}
84    #exclude_package_data =     {}
85    entry_points =         None,
86    test_suite =                   'ndg.security.test',
87    zip_safe =             False
88)
Note: See TracBrowser for help on using the repository browser.