source: TI12-security/trunk/python/ndg.security.common/setup.py @ 2238

Subversion URL: http://proj.badc.rl.ac.uk/svn/ndg/TI12-security/trunk/python/ndg.security.common/setup.py@2238
Revision 2238, 2.7 KB checked in by pjkersha, 14 years ago (diff)

Updated setup.py to include M2Crypto dependency_link but this is not working

Line 
1#!/usr/bin/env python
2
3"""Distribution Utilities setup program for NDG Security Package
4
5NERC Data Grid Project
6
7P J Kershaw 24/04/06
8
9Copyright (C) 2006 CCLRC & NERC
10
11This software may be distributed under the terms of the Q Public License,
12version 1.0 or later.
13"""
14# Bootstrap setuptools if necessary.
15from ez_setup import use_setuptools
16use_setuptools()
17
18from setuptools import setup, find_packages
19
20import os, sys
21
22reposID = "$Id:$"
23
24
25# Packages needed for NDG Security
26# Note commented out ones fail with PyPI - use explicit link instead
27# TODO: subdivide these into server and client specific and comon dependencies
28_pkgDependencies = [
29    'ZSI',
30    'pycrypto',
31    'SQLObject',
32#    'MySQL-python', - gcc: unrecognized option `-restrict'
33]
34
35# Python 2.5 includes ElementTree by default
36if sys.version_info[0:2] < (2, 4):
37    _pkgDependencies += ['ElementTree', 'cElementTree']
38
39# Sledge hammer approach needed with some packages as they won't install from their PyPI name -
40# instead give the explicit URL.  This may cause problems later!
41_pkgDependencyLinks = [
42    # Custom M2Crypto for use with Python MyProxy client
43    "http://proj.badc.rl.ac.uk/ndg/browser/TI12-security/branches/Dependencies/m2crypto/dist/M2Crypto-0.16-py2.4-linux-i686.egg?format=raw",
44    "ftp://ftp.4suite.org/pub/4Suite/4Suite-XML-1.0.tar.gz",
45    "http://prdownloads.sourceforge.net/pyxml/PyXML-0.8.4.tar.gz?use_mirror=kent"
46    # Twisted won't install as an egg
47#    "http://tmrc.mit.edu/mirror/twisted/Web/0.5/TwistedWeb-0.5.0.tar.bz2",
48#    "http://tmrc.mit.edu/mirror/twisted/Twisted/2.2/TwistedSumo-2006-02-12.tar.bz2",
49]
50
51
52setup(
53    name =                      'ndg.security.common',
54    version =                   '0.7.2',
55    description =               
56'''NERC DataGrid Security virtual package containing common utilities used
57noth by server and client packages''',
58    long_description =          'Software for securing NDG resources',
59    author =                    'Philip Kershaw',
60    author_email =              'P.J.Kershaw@rl.ac.uk',
61    maintainer =                'Philip Kershaw',
62    maintainer_email =          'P.J.Kershaw@rl.ac.uk',
63    url =                       'http://proj.badc.rl.ac.uk/ndg',
64    install_requires =          _pkgDependencies,
65    dependency_links =          _pkgDependencyLinks,
66    packages =                  find_packages(),
67    namespace_packages =        ['ndg', 'ndg.security'],
68    # This flag will include all files under SVN control or included in
69    # MANIFEST.in.
70    #'include_package_data =    True,
71    # Finer grained control of data file inclusion can be achieved with
72    # these parameters.  See the setuptools docs.
73    #'package_data =            {}
74    #'exclude_package_data =    {}
75    entry_points =         None,
76    test_suite =                   'ndg.security.test',
77    zip_safe =             False
78)
Note: See TracBrowser for help on using the repository browser.