source: TI01-Discovery-service-BUILDOUTS/trunk/ndg-OaiInfoEditor-service/buildout.cfg @ 6449

Subversion URL: http://proj.badc.rl.ac.uk/svn/ndg/TI01-Discovery-service-BUILDOUTS/trunk/ndg-OaiInfoEditor-service/buildout.cfg@6449
Revision 6449, 1.8 KB checked in by sdonegan, 10 years ago (diff)

Neptune version - works with configurable oai_document_ingester and takes oai config file location from editor.conf. Tested and returns to home page properly- though need to check proper ingest functionality

Line 
1#
2# zc.buildout config for the NDG Discovery Service
3#
4# P J Kershaw 02/06/09
5#
6[buildout]
7parts = OAI_Info_Editor_NDG3
8#develop = passwords
9
10# Configuration mirroring eggs as currently deployed on proglue
11[OAI_Info_Editor_NDG3]
12recipe = collective.recipe.modwsgi
13interpreter = python2.5.1
14extra-paths = ${buildout:directory}/ingestConfig, ${buildout:directory}/ingestAutomation-upgrade/OAIBatch
15
16
17# Versioning:
18#
19# 1) Explicit Pylons and WebHelpers versions required otherwise code
20# breaks with WebHelpers 0.6.4 with:
21#
22# File "/usr/local/ndg-discovery/eggs/ows_server-0.0.0dev_r5354-py2.5.egg/ows_server/config/environment.py", line 22, in load_environment
23# tmpl_options['myghty.escapes'] = dict(l=webhelpers.auto_link, s=webhelpers.simple_format)
24# AttributeError: 'module' object has no attribute 'auto_link'
25#
26# 2) cdat_lite should be fixed at 4.1.2 to imitate the proglue settings
27# but this build fails.  Using >=, cdat_lite 5 is installed but there
28# are then issues with the code not able to find cdms because of the
29# change to cdms2. e.g.
30#
31# http://ndg3beta.badc.rl.ac.uk/services/view/grid.bodc.nerc.ac.uk__DIF__grid.bodc.nerc.ac.uk-DIF-EDMED1048001
32#
33# Left as an open issue because discovery service is likely to be upgraded to
34# the latest version anyway
35eggs = 
36        ows_common==0.1dev_r2969
37        ndgCommon==0.1.1.dev_r5917
38        csml==2.1b_r3917
39        cdat_lite>=4.1.2_0.2.5
40#       cdat_lite==4.1.2_0.2.5
41        Pylons==0.9.6.2 # changed from 0.9.6.1 to get oai editor going
42        PyGreSQL==3.8.1
43        PasteScript
44        WebHelpers==0.3.2
45        oai_info_editor==0.0.0dev_r6428
46        oai_document_ingester==3.0.0.dev_r6421
47        Routes==1.7.3
48        AuthKit==0.4.3ndg_r174
49        ndg_security_server # Comment out whilst 4Suite-XML ftp site is down 17/07/09 PJK
50config-file = ${buildout:directory}/secured.ini
51find-links = http://ndg.nerc.ac.uk/dist
52        http://ndg.nerc.ac.uk/dist/archivedcsml
Note: See TracBrowser for help on using the repository browser.