source: TI01-Discovery-service-BUILDOUTS/trunk/ndg-OaiInfoEditor-service/buildout.cfg @ 6328

Subversion URL: http://proj.badc.rl.ac.uk/svn/ndg/TI01-Discovery-service-BUILDOUTS/trunk/ndg-OaiInfoEditor-service/buildout.cfg@6328
Revision 6328, 2.0 KB checked in by sdonegan, 11 years ago (diff)

buildout with fixed versions of Beaker, Routes, numpy & httplib2 - works but probs with oai_doc_ingester (but not a buildout prob)

Line 
1#
2# zc.buildout config for the NDG Discovery Service
3#
4# P J Kershaw 02/06/09
5#
6[buildout]
7parts = OAI_Info_Editor_NDG3
8#develop = passwords
9
10# Configuration mirroring eggs as currently deployed on proglue
11[OAI_Info_Editor_NDG3]
12#recipe = collective.recipe.modwsgi
13recipe = zc.recipe.egg
14extra-paths = ${buildout:directory}/passwords
15              ${buildout:directory}/oaiInfoEditorData
16              ${buildout:directory}/oaiInfoEditorDataBackups
17              ${buildout:directory}/data
18unzip = true
19# Versioning:
20#
21# 1) Explicit Pylons and WebHelpers versions required otherwise code
22# breaks with WebHelpers 0.6.4 with:
23#
24# File "/usr/local/ndg-discovery/eggs/ows_server-0.0.0dev_r5354-py2.5.egg/ows_server/config/environment.py", line 22, in load_environment
25# tmpl_options['myghty.escapes'] = dict(l=webhelpers.auto_link, s=webhelpers.simple_format)
26# AttributeError: 'module' object has no attribute 'auto_link'
27#
28# 2) cdat_lite should be fixed at 4.1.2 to imitate the proglue settings
29# but this build fails.  Using >=, cdat_lite 5 is installed but there
30# are then issues with the code not able to find cdms because of the
31# change to cdms2. e.g.
32#
33# http://ndg3beta.badc.rl.ac.uk/services/view/grid.bodc.nerc.ac.uk__DIF__grid.bodc.nerc.ac.uk-DIF-EDMED1048001
34#
35# Left as an open issue because discovery service is likely to be upgraded to
36# the latest version anyway
37eggs = 
38        ows_common==0.1dev_r2969
39        ndgCommon==0.1.1.dev_r5917
40        csml==2.1b_r3917
41        cdat_lite>=4.1.2_0.2.5
42#       cdat_lite==4.1.2_0.2.5
43        Pylons==0.9.6.2 # changed from 0.9.6.1 to get oai editor going
44        WebHelpers==0.3.2
45        oai_info_editor==0.0.0dev_r6270
46        oai_document_ingester==3.0.0
47        Beaker==1.4.2 #fixed to get working...
48        Routes==1.7.3 #fixed to get working 18/01/10 10:24
49        numpy==1.3.0 #fixed to get working 18/01/10 10:24
50        httplib2==0.5.0 #fixed to get working 18/01/10 10:24
51        PasteScript
52        PyGreSQL==3.8.1
53config-file = ${buildout:directory}/development.ini
54find-links = http://ndg.nerc.ac.uk/dist
55        http://ndg.nerc.ac.uk/dist/archivedcsml
Note: See TracBrowser for help on using the repository browser.