Changeset 938 for CMIP6dreqbuild


Ignore:
Timestamp:
24/01/17 20:17:35 (3 years ago)
Author:
mjuckes
Message:

added warning when supplement version does not match main doc

File:
1 edited

Legend:

Unmodified
Added
Removed
  • CMIP6dreqbuild/trunk/src/framework/dreqPy/dreq.py

    r935 r938  
    489489    self.ttl2 = [] 
    490490    self.docs = {} 
     491    self.version = None 
    491492 
    492493    if manifest != None: 
     
    561562        self.ns = None 
    562563      vl = root.findall( './/{http://purl.org/pav/2.3}version' ) 
    563       self.version = vl[0].text 
     564      if self.version != None: 
     565        if vl[0].text != self.version: 
     566          print ('WARNING: version difference between %s [%s] and %s [%s]' % (self.docl[0][0],self.version,thisdoc,vl[0].text) ) 
     567      else: 
     568        self.version = vl[0].text 
    564569      self.parent_map = dict((c, p) for p in root.getiterator() for c in p) 
    565570    else: 
Note: See TracChangeset for help on using the changeset viewer.