Warning: Can't synchronize with repository "ojims" (/svn/ojims does not appear to be a Subversion repository.). Look in the Trac log for more information.

Ticket #670 (closed defect: fixed)

Opened 7 years ago

Last modified 7 years ago

Unable to install JAP on Centos

Reported by: lawrence Owned by: iwi
Priority: major Component: JASMIN Analysis Platform
Keywords: Cc:

Description

Am trying to install on a fresh copy of CentOS 6.5:

I followed instructions on the installation page as to setting up EPEL and JAP rpms ... and hit yum (all copied and pasted), and got

...
---> Package texlive-texmf-errata-latex.noarch 0:2007-7.1.el6 will be installed
---> Package texlive-texmf-fonts.noarch 0:2007-38.el6 will be installed
--> Processing Dependency: texlive-texmf-errata-fonts = 2007 for package: texlive-texmf-fonts-2007-38.el6.noarch
--> Running transaction check
---> Package grib_api.x86_64 0:1.12.0-3.el6 will be installed
--> Processing Dependency: libnetcdf.so.6()(64bit) for package: grib_api-1.12.0-3.el6.x86_64
---> Package texlive-texmf-errata-fonts.noarch 0:2007-7.1.el6 will be installed
--> Finished Dependency Resolution
Error: Package: grib_api-1.12.0-3.el6.x86_64 (epel)

Requires: libnetcdf.so.6()(64bit)
Available: netcdf-4.1.1-3.el6.5.x86_64 (epel)

libnetcdf.so.6()(64bit)

Available: netcdf-4.2.1-3.ceda.el6.x86_64 (ceda)

Not found

Installing: netcdf-4.3.1-1.ceda.el6.x86_64 (ceda)

Not found

You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

Attachments

armadillo-3.800.2-1.el6.x86_64.rpm (16.4 KB) - added by lawrence 7 years ago.
Older version of armadillo needed for GDAL and friends
armadillo-3.800.2-1.el6.src.rpm (3.1 MB) - added by lawrence 7 years ago.
Armadillo Source

Change History

comment:1 Changed 7 years ago by spascoe

  • Owner changed from spascoe to iwi
  • Status changed from new to assigned

Alan, can you take this on? It looks like the grib_api RPM needs updating or not all NetCDF RPMs are copied to dist.ceda.ac.uk.

comment:2 Changed 7 years ago by iwi

Sorry for delayed response.

The problem is that there is now a later version of grib_api available in the epel repository (1.12.0) than what we have in JASMIN-repo (1.10.0), but that version is built against an earlier netCDF (it wants libnetcdf.so.6 and on JASMIN we have libnetcdf.so.7). The meta-RPM depends on ">= 1.10.0-1.ceda", so by preference it chooses the latest available, assuming that the repositories have equal priority. Our options are either:

  • force it to use our CEDA build of 1.10 by preference
  • rebuild our own version of grib_api at >= 1.12 and publish in dist

There are issues raised by both of these options, and I think Stephen and I need to have a conversation about it outside of the confines of this ticket.

As a workaround for now, could you just locally add to /etc/yum.repos.d/jasmin.repo the line:

priority = 10

and in epel-tier1.repo in the same directory:

priority = 20

(noting that lower number means higher priority).

I believe that it should then just work.

I will keep this ticket open until we've fixed it properly (even if we decide that this just means automating or at least documenting the above workaround).

Last edited 7 years ago by iwi (previous) (diff)

comment:3 Changed 7 years ago by lawrence

I've only just got back to this. I've started again from a fresh centos 6.5, and now I get this:

--> Finished Dependency Resolution
Error: Package: gdal-ruby-1.9.2-1.ceda.el6.x86_64 (ceda)
           Requires: libarmadillo.so.3()(64bit)
Error: Package: gdal-1.9.2-1.ceda.el6.x86_64 (ceda)
           Requires: libarmadillo.so.3()(64bit)
Error: Package: gdal-java-1.9.2-1.ceda.el6.x86_64 (ceda)
           Requires: libarmadillo.so.3()(64bit)
Error: Package: gdal-libs-1.9.2-1.ceda.el6.x86_64 (ceda)
           Requires: libarmadillo.so.3()(64bit)
Error: Package: gdal-perl-1.9.2-1.ceda.el6.x86_64 (ceda)
           Requires: libarmadillo.so.3()(64bit)
Error: Package: grib_api-1.12.1-1.el6.x86_64 (epel)
           Requires: libnetcdf.so.6()(64bit)
           Available: netcdf-4.1.1-3.el6.5.x86_64 (epel)
               libnetcdf.so.6()(64bit)
           Available: netcdf-4.2.1-3.ceda.el6.x86_64 (ceda)
               Not found
           Installing: netcdf-4.3.1-1.ceda.el6.x86_64 (ceda)
               Not found
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

At this point I don't have a jasmin.repo file to edit. Should I create one?
It also looks like I'll have to deal with a problem in gdal ...

Should I go back to centos6.4 since that's what you test with?

comment:4 Changed 7 years ago by lawrence

Actually, I just tried centos 6.4. Same error.

comment:5 Changed 7 years ago by lawrence

So we fixed the netcdf problem by adding an exclude line here:

[epel]
name=Extra Packages for Enterprise Linux 6 - $basearch
#baseurl=http://download.fedoraproject.org/pub/epel/6/$basearch
mirrorlist=https://mirrors.fedoraproject.org/metalink?repo=epel-6&arch=$basearch
failovermethod=priority
enabled=1
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-EPEL-6
exclude=grib_api*

that's the last line in the first section epel.repo, found in /etc/yum.repos.d. What this has done is deal with the fact that the EPEL version has built grib-api with an older version of netcdf, and CEDA has built it with a new version. We just make sure we don't go near the EPEL version. (A better solution in the long term will involve priorities as hinted above, but this is a hack ...)

Last edited 7 years ago by lawrence (previous) (diff)

Changed 7 years ago by lawrence

Older version of armadillo needed for GDAL and friends

comment:6 Changed 7 years ago by lawrence

The second problem can be fixed by downloading the armadillo attachment and doing a

yum localinstall armadillo-3.800.2-1.el6.x86_64.rpm

before your
yum install jasmin-sci-vm

Last edited 7 years ago by lawrence (previous) (diff)

Changed 7 years ago by lawrence

Armadillo Source

comment:7 Changed 7 years ago by lawrence

Since this ticket effectively distributes the armadillo binary, we've added the source as well for license compliance.

comment:8 Changed 7 years ago by iwi

  • Status changed from assigned to closed
  • Resolution set to fixed

Time to close this ticket. There are instructions at http://proj.badc.rl.ac.uk/cedaservices/wiki/JASMIN/AnalysisPlatform/Installation#RPMs that include CentOS and have been tested recently. These include workarounds for the RPM conflict issues discussed above.

Note: See TracTickets for help on using tickets.